FreeCAD

FreeCad est un modeleur 3D à conception paramétrique. La conception paramétrique permet d'éditer facilement votre design en remontant dans l'historique du modèle afin d'en changer les paramètres. FreeCAD est libre (licence LGPL) et complètement modulaire, permettant ainsi une personnalisation poussée. FreeCAD est multi-plateforme, ouvre et sauvegarde plusieurs formats de fichiers ouverts tels que STEP, IGES, STL et d'autres. (freecadweb.org)

Installation

Installer de préférence la version stable “Stable FreeCAD installers” sur la page Download. Ce logiciel est en constant développement, des nouveautés, changements apparaissent au fil des différentes versions. Cela peut être risqué en situation de production, mais d'un autre côté l'avantage est de pouvoir ajouter de nouvelles fonctionnalités à télécharger avant qu'elles ne soient intégrées à la version stable suivante.

Sur Windows après l'installation pensez aux préférences (Édition> Préférences > Affichage > Souris) pour configurer la souris comme vous le souhaitez pour dessiner, sélectionner, vous déplacer dans la vue 3d… Ici nous optons pour l'option Blender de navigation…

Présentation

Le logiciel propose plusieurs fonctionnalités qui sont regroupés dans des ateliers. Il en existe aujourd'hui (FreeCad 0.16) une vingtaine.

Les principaux ateliers :

  • Arch : atelier architectural
  • Part design : dessiner une pièce en 2d puis l'extruder ou faire révolution, …
  • Part : assembler plusieurs pièces avec des opérations booléennes d'union, soustraction, intersection, …
  • Draft : outils de dessins, de déplacement et d'accrochage
  • Drawing : créer une mise en plan (remplacé par “TechDraw” dans la version 0.17) + Macro Cartouche
  • Mesh Design : modifier, exporter les objets maillés (STL)
  • Spreadsheet : créer et manipuler des données dans une feuille de calcul, qui peuvent être partagées dans tout le projet

Autres :

  • Assembly 2 : à télécharger, assembler des objets enregistrés en fichiers Freecad
  • Drawing Dimensioning : à télécharger, pour ajouter des cotations à la mise en plan

Prise en main

Une quinzaine de cours en français très bien faits sur le canal vidéo de Cad printer

Autres tutoriels sur le site de Freecad : Basic modeling

Ateliers

Part Design

Voici la routine pas à pas pour créer une forme 3d:

  1. On crée une esquisse dans laquelle on ajoute des lignes et des points
  2. On ajoute à ce dessin des contraintes (longueur, distances, tangente, rayon, …) en cliquant sur les segments et les points
  3. On ferme l'esquisse
  4. On applique une transformation 3D (Protrusion=extrusion, cavité, révolution)
  5. On peut finir l'objet en ajoutant des chanfreins, congés. C'est conseillé de le faire à la toute fin.

Part

Créer un verre avec épaisseur

  1. Aller dans l'atelier PART et créer un nouveau document
  2. Créer trois primitives géométriques paramétrées de formes hexagonales (polygone 6) : 30mm / 35mm Axe Z : 40 / 40mm Axe Z : 80
  3. Fermer le mode édition
  4. Cliquer sur lissage de profils (“loft”)
  5. Sélectionner les trois profils dans l'ordre avec la flèche et cocher “Créer un solide”
  6. Modifier le placement et la rotation des polygones dans l'onglet “Données” qui s'affiche quand on sélectionne un objet
    1. 2ème polygone angle 10° en rotation (axe Z)
    2. 3ème polygone angle 20° en rotation (axe Z)
  7. Il est toujours de possible de changer la taille dans “Données”
  8. Sélection de la face du haut et cliquer sur “Évidemment d'un solide” (“Thickness”)
    1. La valeur de l'épaisseur quand elle est positive se fait à l'extérieur de l'objet, on peut faire l'inverse en mettant une valeur négative
    2. Un conseil : décocher “Réactualiser la vue” car l'opération est très longue à chaque modification
    3. Le type de raccordement permet d'avoir des courbes (“Arc”) ou des angles pointus (“Intersection”)
    4. On peut aussi sélection d'autres faces en cliquant sur “Face”
  9. Exporter en STL

Créer un cube troué

  1. dans l'atelier PART : créer un cube
  2. éditer la taille du cube (dans l'onglet donnée en bas a gauche) : 100mx100mmx100mm
  3. Aller dans PART DESIGN : faire une esquisse libre, et placer un cercle de 40mm de rayon a 50,50 mm
  4. dupliquer cette esquisse 6 fois
  5. associer chaque esquisse a une face du cube (5eme icône a coté de l'icône nouvelle esquisse) et faire une cavité de 20mm pour chaque esquisse/face de cube
  6. une fois appliqué“ sur chacune des 6 faces, un petit cube sera contenu dans le grand
  7. il faudra ensuite réitérer les 4 étapes précédentes sur petit cube, cette fois en perçant complètement…

Drawing dimensionning

L'atelier DRAWING associé à d'autres éléments permet de créer une mise en plans de vos objets 3D.

Installation :

  1. Télécharger le plugin FreeCAD_drawing_dimensioning
  2. Aller dans Macro, et relever le repertoire ou sont situé les macro et créer un repertoire Mod et glisser le dossier extrait FreeCAD_drawing_dimensioning dedans)

Création d'un cartouche d'info (facultatif):

  1. Créer une nouvelle macro
  2. Copier le texte de la Macro Cartouche et la copier dans l'éditeur de Macro.
  3. Télécharger les templates associées à cette macro : templates_cartouche.zip
  4. Copier ces quatre fichiers svg dans ”/usr/share/freecad/Mod/Drawing/Templates“ pour Linux ou “C:\Program Files\FreeCAD 0.16\data\Mod\Drawing\Templates” pour Windows

Créer la page et les côtes :

  1. Si plusieurs objets, il faut faire une Union des objets dans l'atelier PART.
  2. Aller dans l'atelier DRAWINGDimensionning, créer une feuille A3 (ou A4) dont le nom finit par “FR_FULL”, ce sont les nouveaux “templates” que l'on vient d'installer
  3. Sélectionner l'objet (dans l'arborescence)
  4. Bouton “insérer une forme une projection orthogonale d'une forme sur la feuille active”
  5. Ajouter des dimensions linéaires, etc.

Draft

Arch

Assembly 2

Importer / exporter

Importer un SVG (Inkscape)

Pour importer un fichier DXF, il suffit d'aller dans Fichier > Importer, mais avec Inkscape, nous n'avons pas toujours le résultat attendu. Est présentée ici une solution pour importer les dessins d'Inkscape dans Freecad.

Dans Inkscape


Définir l'origine en bas à gauche, le plus simple est de sélectionner la forme et d'appuyer sur “Ajuster la page au dessin” dans Fichier > Propriétés du document


Convertir les objets en chemins


Enregistrer au format SVG optimisé

Dans FreeCad


Importer le SVG (geometry)


Dans “Draft”, sélection du fond et appuyer sur la Flèche Haut pour fermer la former, créer des faces. La même chose ensuite avec les trous


Dans “Part”, union des trous


Appliquer la différence entre les trous et le fond


Extrusion


Placement


Clonage

Importer un DXF

Créer du gcode cnc avec Freecad